Article: 4130041
Issue
VSS snapshot errors are presented in the AppAssure event log and snapshots do not occur.
Cause
The problem is caused by an unstable or failed writer.
Solution
Follow the steps below to diagnose and solve the problem.
- Run VSHADOW located in the AppAssure installation directory under Replay Agent\Utils or Replay Agent\Utils64 to determine the cause of the problem. Make sure to reboot if one of the writers is in a failed state and then try again one more time with VSHADOW before excluding the writer.
- If the Exchange services are running on this machine, bounce the Microsoft Exchange Information Store service.
- If the writer has failed during the snapshot, use the steps below to exclude the failed writers.
- Run the Command Prompt (cmd) on the Agent side
- Type vssadmin list writers to list all the VSS writers with the state, name and ID of each one. Each writer will be displayed like the example below:
Writer name: ‘xxxxxxx xxxxxxx’
Writer Id: {xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx}
Writer Instance Id: {e5914b11-5072-4857-a36e-99a3cdff90e4}
State: [5] No error
Last error: No error
- Copy or make a note of the writer id (sans curly braces) of the writer you would like to exclude.
- Stop the Replay Agent service and open up the registry (REGEDIT) then navigate to: HKLM>Software>AppAssure>ReplayEPS. Create a new registry string vss_excluded_writer_ids and give it the writer ID you copied earlier for the one to exclude.
- Restart the Replay Agent server and attempt to snapshot.